ERROR: rvm requires autoreconf pada saat Install Ruby dengan RVM

Setelah lama tidak belajar ruby on rails.. kmrin aku memulai lagi dengan install Ruby dengan RVM di Ubuntu 11.1 Aku menggunakan referensi http://beginrescueend.com/rvm/install/.  Tetapi ketika mengetikan perintah untuk menginstall ruby muncul error di terminal :

ERROR: rvm requires autoreconf to install the selected ruby interpreter however autoreconf was not found in the PATH.

Aku googling untuk mencari solusinya.. Dan akhirnya nemu artikel ini http://www.linuxguy.in/error-rvm-requires-autoreconf/. Solusinya adalah dengan menginstall package automake dengan perintah berikut:


apt-get install automake

Kemudian install ruby dengan RVM pun lancar..

Sekian

ERROR: rvm requires autoreconf

Tutorial Rails : Installasi Ruby 1.9.2 dan Rails 3.0.3 di Linux Ubuntu 10.04

Hei reader…:D

Mulai saat ini aku akan membiasakan diri menjadi pengguna linux (ubuntu)..hehehe. Seblumnya aku belajar rails pake Windows dan memang pada kasus2 tertentu saat develop aplikasi dg Ruby on Rails di windows perlu perlakuan khusus (red:sulit). Padahal, di linux bisa dilakukan hanya dengan command yng sangat pendek. Beberapa senior aku yng jago rails jg merekomendasikan pake linux untuk  belajar framework Ruby on Rails, so… aku putuskan mulai saat ini untuk membiasakan dgn linux (UBUNTU 10.04)… #kadang2 balik pake windows gpp kan???…hihi..

Baik.. pada kesempatan kali ini aku tulis langkah-langkah Installasi Ruby 1.9.2 dan Rails 3.0.3 di Linux Ubuntu 10.04. Ini adalah lingkungan baru buat aku, dan aku berharap aku akan menikmatinya…ckckck..

Sebelum melakukan instalasi Ruby on Rails, kita lakukan update package library terlebih dahulu dengan command:

 $ sudo apt-get update

Installasi Ruby 1.9.2

1.  Install beberapa library yang dibutuhkan pada saat installasi Ruby on Rails nanti

 $ sudo apt-get install build-essential libssl-dev libreadline5 libreadline5-dev zlib1g zlib1g-dev

2. Install ruby dari source (http://www.ruby-lang.org) dgn command2 berikut:

$ mkdir ~/src && cd ~/src

 

$ wget http://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p136.tar.gz

 

$ tar -zxvf ruby-1.9.2-p136.tar.gz 

 

$ cd ruby-1.9.2-p136/

 

$ ./configure && make && sudo make install

3. Cek versi Ruby yng telah terinstall dengan:

 $ ruby --version

Jika instalasi berhasil maka akan muncul :

ruby 1.9.2p136 (2010-12-25 revision 30365) [x86_64-linux]

Update RubyGems

Ruby menggunakan sebuah paket manajemen sistem yng dikenal dengan nama RubyGems yng digunakan untuk mengatur instalasi dan maintenance program Ruby dan Library2nya. Lakukan update RubyGems dengan perintah berikut:

$ sudo gem update --system

Install Rails 3.0.3

Untuk installasi rails 3.0.3 kita cukup mengetikan satu baris perintah seperti berikut:

$ sudo gem install rails -v=3.0.3 

Setelah selesai, cek versi Rails dengan perintah :

 rails --version

Jika instalasi sukses maka akan muncul sperti berikut:

Rails 3.0.3

Sampai disini proses installasi Ruby 1.9.2 dan Rails 3.0.3 di Ubuntu 10.04 telah selesai. Untuk memastikan apakah Ruby on Rails sudah berjalan di Ubuntu kita, maka kita akan coba membuat sebuah project Rails, ketikan perintah berikut:

$rails new hello

Masuk ke direktori ‘hello’, kmudian jalankan server dengan:

$rails server

Jika berhasil maka akan tampil sperti berikut:

Tampilan Awal Rails

Tampilan Awal Rails